含有章节索引的中文 文章模板

-- limodou [2004-09-03 03:04:09]

pyBlosxom的安装及配置

个人测试经历

安装准备

其实原来Linux中已经带有一个2.2版本的 Python 了,但我为了使用最新了,自行下载了2.3.4版本,编译后安装了。结果发现Apache在处理pyblosxom.cgi(pyBlosxom的入口文件)时会报错,而这个文件在命令行下单独运行时是正常的。我感觉是Apache可能还是使用老的python 2.2版本来处理的,但由于pyBlosxom是安装在 2.3.4 上的,因此报错。于是我修改了pyblosxom.cgi文件的第一行:#!/usr/bin/evn python为 #!/usr/local/bin/python (我机器上的Python实际安装文件)。一切OK了。

正式安装

# Blog的标题
py['blog_title'] = "limodou's blog"

# Blog的描述用于RSS Feed
py['blog_description'] = "remember what I saw and what I thought"

# Blog作者的用户名和邮箱
py['blog_author'] = "limodou chatme@263.net"

# Blog的主要语言用于Rss Feed
py['blog_language'] = "zh"

# 输出编码
py['blog_encoding'] = "utf-8"

# Blog日志存放路径
py['datadir'] = "entries"

# 日志文件存放路径
py['logdir'] = "logs"

Testing!
this is my first blog entry! 

<VirtualHost *:80>
        DocumentRoot /var/www/html

        ServerAdmin chatme@263.net
        ServerName 127.0.0.1

        <Directory "/var/www/html/*/">
                Options ExecCGI
                DirectoryIndex pyblosxom.cgi
                <Files config.py>
                        deny from all
                </Files>
        </Directory>
</VirtualHost>

PyBlosxomIniLimodou (last edited 2009-12-25 07:15:22 by localhost)